This is a public Forum  public

Service & Maintenance Question

    Stephen Bilancia
    I purchased a Weed Eater Smartcut on May 1, 2011. Used it...escalated
    Service & Maintenance Question posted May 16, 2012 by Stephen Bilancia, last edited May 23, 2012 
    316 Views, 1 Comment
    Question:
    I purchased a Weed Eater Smartcut on May 1, 2011. Used it for one season...but during the season it seemed to slow in speed of moving forward and reverse. Tuned it up before the start of this season...spark plug, oil, filter...etc. On May 11, 2012 was cutting the grass and it stopped moving completely. No forward, no reverse. The motor runs great, blade engages fine. Lifted up the back end with jack stands...and do see the friction disk and friction wheel are spinning when placed in forward or reverse, however the wheels will not turn. I checked to see if the parking brake was engaged...it was not. When up on jack stands, the wheels turn freely.

    I called Weed Eater and was told to contact a warranty service center. They only have 5 in my area. 3 are no longer in business, 1 had no idea they are a service center and would not look at it under warranty, and the last 1 said they will not deal with Weed Eater any longer because of their history. Right now I have a $1000 lawn ornament. Any ideas on how to proceed? My next step is to roll it to the curb (if I can) and put a free sign on it.

    Please help....

    Stephen

    Answer

     

    • Stephen Bilancia

      I wanted to update on my previous post.  I never received any additional help from Weed Eater/Husqvarna other than to be told it was my problem to deal with.  My post with answerarmy was never responded to either.  Guess Weed Eater/Husqvarna doesn't want to stand by their products.

      I ended up trading it in to a local lawn care shop for a much better product.  When they came to pick up my Smartcut, I was questioned as to what was wrong and let them know the motor ran, blade engages however will not move when placed in gear.  They told me they just received another trade (Weed Eater One) with the exact same problem.  Seems to be common for these Weed Eaters.  Looks like Weed Eater has a poor design and doesn't seem to see the need to fix their issue with this nor care for their customers once their product has been purchased.

      That being said...I don't think I'll be buying "ANY" Weed Eater/Husqvarna product in the future.

      Very dissatisfied with how this was treated.

      Stephen